1043 输出PATest (20 分)
给定一个长度不超过 104 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest.... 这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。
输入格式:
输入在一行中给出一个长度不超过 104 的、仅由英文字母构成的非空字符串。
输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例:
redlesPayBestPATTopTeePHPereatitAPPT
输出样例:
PATestPATestPTetPTePePee
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
String inputString = scanner.nextLine();
char[] baseChars = {'P', 'A', 'T', 'e', 's', 't'};
int[] counts = new int[300];
int sum = 0;
for (int i=0; i<inputString.length(); ++i) {
char ch = inputString.charAt(i);
for (int j=0; j<baseChars.length; ++j) {
if (ch==baseChars[j]) {
++sum;
counts[ch]++;
}
}
}
while(sum>0) {
for (int i=0; i<baseChars.length; ++i) {
if (counts[baseChars[i]]>0) {
--counts[baseChars[i]];
--sum;
System.out.print(baseChars[i]);
}
}
}
System.out.println();
}
}